Forwarding Mails to Zammad - Customer behaviour?


  • Used Zammad version: 3.4.x
  • Used Zammad installation source: source
  • Operating system: CentOS Linux 7
  • Browser + version: Chrome / latest

Expected behavior:

  • When someone forwards a mail to our support-mail, I want the customer to be the actual sender of the mail, not the forwarder

Actual behavior:

  • The forwarder is set as customer

Steps to reproduce the behavior:

  • forward an E-Mail

Is there any chance or any possibility, that when someone forwards an E-Mail to our it-support mail for zammad, that the original sender is set as customer? When my boss forwards an E-Mail he receives for example then he is the customer instead of the original sender. Also, the customer doesn’t get an E-Mail with the trigger I set up, even though i explicitly set up a trigger where “Channel” says “E-Mail”.

To make it very short: No.

A bit more context:
The reason is the way a forward works.
Forwarding a mail from your mail account to another means that your mail client will remove all references and header information. The only thing that will help to see if the mail has been forwarded is the quotation header that your client adds.

However: This is not a good thing to filter for, because there might be more than one and it may be missing / invalid etc etc.

Your boss has to redirect the message to solve this issue.
Redirecting however must be supported by your mail server and client.
This action leaves original sender information within the mails header.

Thunderbird and Outlook do support this action, however, it’s a pain in the butt with Outlook (deep context menues - very frustrating task).

Another option would be to have a shared mailbox where to move mails to which Zammad fetches. This technically could also be the bosses account directly, but this would require Zammad to know the bosses password which imho is not the best part.

I’m sure the reason is above information, however, without the trigger configuration nobody will be able to help you based on these information, sorry.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.