[fixed] CSS file not found in Chrome after upgrade to 4.0


  • Used Zammad version: 4.0
  • Used Zammad installation source: RPM
  • Operating system: CentOS 8
  • Browser + version: Chrome 89.0.4389.114

Expected behavior:

  • Page should load ok without errors

Actual behavior:

  • Update from 3.6 to 4.0 via package manager update went fine. also updated elastic in correct order. Then rebooted the server. In Chrome the page loads but CSS gone wild. Screenshot:

    Then tried in Firefox and everything looks ok. So focused on my Chrome (cleared cache, cookies, etc) but no luck. Same behavior!

Tried on a different PC. On this one Chrome & Firefox are both broken. Sample of Firefox:

I’m not too familiar with browser debugging, but checked developer toolbar in Chrome and found errors that some CSS & JS could not be found.

E.g. the file “assets/application-9f83ddd88e7266adce3667b567d9e78506a689665ba1c383d9ed073977528861.css” cound not be found.
In /opt/zammad/public/assets/ I do have a lot of application- files, but indeed none with 9f8 and so on.

Not sure if this is something computed, or needs to be physically there. The Firefox on my workstation loads this file. But Chrome on my box as well as Chrome&Firefox on the other PC wont load it.

Anyone an idea what this might be? Or how to get it working again? I do have a backup and could revert to 3.6 easily. Just checking if this can be fixed on 4.0.
Let me know if you need more details.
Thanks much for your help.

Did some more investigation and googled similar issues. Found hint on precompile the assets once more.
First thing zammad run rake assets:precompile spit errors that yarn wasnt installed. Also no nodejs and npm was found.
After installing nodejs and yarn, the precompile command ran successfully. Then restarted zammad, and all was fine again.
Here’s the list of commands in case someone hits the same issue:

su - 
cd /tmp/
curl -fsSL https://rpm.nodesource.com/setup_15.x | bash -
yum install -y nodejs gcc-c++ make
curl -sL https://dl.yarnpkg.com/rpm/yarn.repo | sudo tee /etc/yum.repos.d/yarn.repo
yum install yarn
zammad run rake assets:precompile
systemctl restart zammad
1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.