Error 500 on Reports - Ubuntu 16.04 Server


I get the below error when I click the reports button (fresh install).

{“error”:“Unable to process POST at\n#\u003cUserAgent::Result:0x00005637fef9bbe0 @Success=false, @Body=nil, @DaTa=nil, @code=0, @content_type=nil, @error=”#\u003cErrno::ECONNREFUSED: Failed to open TCP connection to (Connection refused - connect(2) for “” port 9200)\u003e"\u003e"}

I’ve tried creating and closing a ticket which works fine, purely an error with reporting. Elastic is running.

I thought I’d try the install on Centos7 which worked fine. Only an issue with Ubuntu.

I’ve seen this is also in the bugs section but I was directed here from:

hey there.
this is the same topic i guess ElasticSearch mit 500er und 400er Fehler

i’ve got the same issue and spend plenty of time resolving this.
in my case my proxy block the installation of the mapper-attachment.
then i’ve got an failure by creating the searchindex (sudo zammad run rake searchindex:rebuild), only because the service of elasticsearch wasn´t restarted and enabled, but running.

with a “clean” internet connection, using the discription at it worked for me. only use elasticsearch 2.4 or 5.5 and don´t update this (delete it from the /etc/apt/sources.list.d/elastic-5.x.list). Because every time the Error comes again…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.