Email Notification

Infos:

  • Used Zammad version:
  • Used Zammad installation source: (source, package, …)
  • Operating system:
  • Browser + version:

version 3.2
ubuntu 18.04 pkg
Linux
Chrome

I am trying to setup email notification and selected to configure outgoing smtp using google. After I input the required fields and submit, I get Authentication failed!

I, [2019-12-10T09:20:01.970508 #1029-47241126976460] INFO – : Started POST “/api/v1/channels_email_notification” for 47.206.44.59 at 2019-12-10 09:20:01 -0500
I, [2019-12-10T09:20:01.973671 #1029-47241126976460] INFO – : Processing by ChannelsEmailController#notification as JSON
I, [2019-12-10T09:20:01.973842 #1029-47241126976460] INFO – : Parameters: {“adapter”=>“smtp”, “options”=>{“host”=>“smtp.gmail.com”, “user”=>“n*****@**********.org”, “password”=>"[FILTERED]", “port”=>“587”}, “channel_id”=>2}
I, [2019-12-10T09:20:02.015039 #1029-47241126976460] INFO – : Enqueued UserDeviceLogJob (Job ID: 10a45d2a-8411-4e6d-8d54-04e5db8e3116) to DelayedJob(default) with arguments: “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36”, “47.206.44.59”, 3, “1019385214”, “session”
I, [2019-12-10T09:20:02.285343 #1029-47241126976460] INFO – : Completed 200 OK in 311ms (Views: 0.2ms | ActiveRecord: 18.4ms)

Please take a look into the docs:
https://admin-docs.zammad.org/en/latest/channels-email.html

I’m sure Google doesn’t just return “authentication failed”, but has a more detailed error message.
If not, your credentials are indeed incorrect.

Thank you. I verified the credentials by logging onto google account using different browsers, I try again, but first I will see if I can setup smtp server and go from there.

Thank you, again.

N