Email input channel - failed imap logins

Infos:

  • Used Zammad version: 3.5
  • Used Zammad installation source: source
  • Operating system: Ubuntu-18.04
  • Browser + version: Google chrome 86.0.4240.111

Description:

I do have a zammad instance. It works quite well.
I use email input channels. Zammad polls an IMAP accout and the emails
end up in new/existing zammad tickets. All fine!

However: On the imap host, I can see failed imap logins coming from the zammad server
using the email account configured within zammad.

Within zammad’s production log, I can see this:

I, [2020-10-29T07:08:58.576874 #445-70169368606760]  INFO -- : execute Channel.fetch (try_count 0)...
I, [2020-10-29T07:08:58.580573 #445-70169368606760]  INFO -- : fetching imap (dovecot/zammad port=993,ssl=true,starttls=false,folder=INBOX,keep_on_server=false,auth_type=LOGIN)
I, [2020-10-29T07:08:58.653439 #445-70169368606760]  INFO -- :  - no message
I, [2020-10-29T07:08:58.653540 #445-70169368606760]  INFO -- : done

No sign of an error. But the login was not successful:

Oct 29 07:08:58 ldap slapd[214]: conn=1052 op=95 BIND dn="uid=zammad,ou=People, dc=XXXX" method=128
Oct 29 07:08:58 ldap slapd[214]: conn=1052 op=95 RESULT tag=97 err=49 text=

Do I have to be worried? Does this happen elsewhere, too?

Expected behavior:

  • Only OK imap logins show up on the imap server

Actual behavior:

  • Some KO imap logins show up on the imap server

Steps to reproduce the behavior:

  • Configure an imap input channel within zammad
  • Verify: Emails end up in zammad tickets - so your configuration is definitely fine
  • Wait a couple of hours/days/weeks/months/years(?) and verify the imap server logs

Mistaken

The issue is a no-issue. My imap server checks the credentials against ldap and a password file. Since the zammad credentials are in the password file only, the ldap check fails permanently. So it is OK.

Please close this thread.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.