Elasticsearch issue | 404 issue

Infos:

Expected behavior:

  • The assets and layouts correctly and I can configure and the admin side and that we can include in one page that the client can log a ticket.

Actual behavior:

  • I got multiple error from assets, although the assets compiled correctly.
  • I successfully assets:precompile the assets not sure why the actual behavior still like cannot find all the assets.

Steps to reproduce the behavior:

    1. during registration for admin I got the error cannot find the image.
  1. The assets (SCSS / Images) are not working properly
    Here are the screenshot:


cannot find any error on the logs:



I also follow this issue log: https://github.com/zammad/zammad/issues/234 using export RAILS_SERVE_STATIC_FILES=tru

This was also posted on:

Please see my answer there and provide the missing information.
Also, please don’t post the same thing on two plattforms, this binds double the time on our end and is unfair to other community users, as we could use that time better.

Hi, sorry I am new here. because I tried to follow the documentation of the installation in zammad.org but still I got the same error. maybe if you can send me the information that my installation is wrong or how can I resolve it alteast give me some idea. because If we will fix the error via our own in the code side we will have some trouble on the update side.

So I knew you are correct that maybe this is from the installation. but however in production.rb I enable the asset precompile, because before it is causing that the public assets cannot connect.

Again if you can help us since we are new in zammad, that will be helpful. and I am sorry community users if this eating lot of time for you to help us.

Regards,
Ryan

I am sorry, but we’re still missing the required information to be able to help you.
Firstly, please provide your webservers zone configuration, for whatever webserver you’re using.

This file contains the information on how the webserver is supposed to contact Zammad.
Also, step by step commands and output you receive might be helpfull, as you might have an issue at a place you don’t recognize it as one (which is perfectly fine).

Beside that, if you want to fiddle less, you could also use the package installation, because it’s a lot easier both in installation and handling during runtime.

Thanks I already fixed it!

Letting the Community know what the issue was would be amazing, so anybody having the same issue can find the resolution. :slight_smile: