ElasticSearch Failed


  • Used Zammad version: 3.6
  • Used Zammad installation source: Repository
  • Operating system: Debian 9.11
  • Browser + version: Firefox

Expected behavior:

  • Elasticsearch running

Actual behavior:

  • ElasticSearch after ten minutes failed

Steps to reproduce the behavior:

  • Good Morning, I have a problem with elasticsearch service.
    The service after about ten minutes failed alone. I attach the error.

Thank You

The service has been killed.

After about 1 hour from runnin has been stopped.

The error has been caused by swap memory of the server.
I have tried this solution Disable swapping | Elasticsearch Reference [5.5] | Elastic and now the service running.

Today again ES has been stopped.

you are running out of memory, either install more memory. Or if you have plenty of RAM available, increase the amount of heap memory java allocate’s and ES can use; Heap: Sizing and Swapping | Elasticsearch: The Definitive Guide [2.x] | Elastic

Thank You for your answer.
I have modified these parameters:
/etc/elasticsearch/elasticsearch.yml --> uncomment bootstrap.memory_lock: true
/etc/default/elasticsearch —> uncomment MAX_LOCKED_MEMORY=unlimited

The ES has been running about 1 day and again has been killed with that error.

The server has this configuration: 2 Core, 8GB RAM

I have tried to modified the value ES_HEAP_SIZE but I haven’t found it in /etc/elasticsearch/elasticsearch.yml or /etc/default/elasticsearch

Where can I Find that value?

it might be an idea to increase it to 2gb.

Thank You

I have used the follow command for set heap size:

export ES_HEAP_SIZE=2g

I hope it

Thank You

Nothink the service has been stoppe with old error…

Failed (result: signal)

(code=killed, signal=kill)

It might get OOM’ed. having 8GB of RAM also doesn’t say much, maybe you have many processes claiming the RAM, leaving nothing left for ElasticSearch. If you feel you identified a memory leak you should report it to the ElasticSearch community or Java if you think it lays there. However such bugs are rare.

Thank for your support.
Yesterday I increased to 16Gb Of Ram.

I hope I have solved the problem

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.