Elasticsearch dropping out

Hey - just wondering if you can help. Zammad is all configured and setup working perfectly… except when it isn’t… I’ll explain…

Sometimes on the reporting I get the error of elasticsearch not being found, or on the users page, no users are shown.

To rectify this I have to reboot the server and run the below commands (sometimes 2 or 3 times)

zammad run rails r "Setting.set('es_url', 'http://localhost:9200')"
zammad run rake searchindex:rebuild

Any idea why it might be doing this? This is day 1 of using Zammad and it’s happened 4 times. Whilst I think it’s an amazing product, it’s a pretty annoying issue to have.

This is the error that keeps popping up every hour or so. A reboot fixes the issue but every hour?!

{"error":"Unable to process GET request to elasticsearch URL 'http://localhost:9200/zammad_production/Ticket/_search'. Elasticsearch is not reachable, probably because it's not running or even installed.\n\nResponse:\n#\u003cUserAgent::Result:0x00005611f4ff2df8 @success=false, @body=nil, @data=nil, @code=0, @content_type=nil, @error=\"#\u003cErrno::ECONNREFUSED: Failed to open TCP connection to localhost:9200 (Connection refused - connect(2) for \\\"localhost\\\" port 9200)\u003e\"\u003e\n\nPayload:\n{:query=\u003e{:bool=\u003e{:must=\u003e[{:term=\u003e{\"create_article_type_id\"=\u003e5}}, {:term=\u003e{\"create_article_sender_id\"=\u003e2}}, {:range=\u003e{\"created_at\"=\u003e{:from=\u003e\"2018-01-01\", :to=\u003e\"2018-12-31\"}}}], :must_not=\u003e[{:term=\u003e{\"state\"=\u003e\"merged\"}}]}}, :size=\u003e0, :aggs=\u003e{:time_buckets=\u003e{:date_histogram=\u003e{:field=\u003e\"created_at\", :interval=\u003e\"month\"}}}}\n\nPayload size: 0M"}

Please check your elasticsearch
“Failed to open TCP connection to localhost:9200 (Connection refused - connect(2)”

Ensure you have enough ram, sounds like it gets killed (or shuts down itself).,

OK - I had VPS with 2GB RAM - now been upgraded to 4GB. I’ll see how it get’s on.

Thanks - all working… I have another question though but I’ll open a new topic with an appropriate title

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.