Disable the password based authentication and enable SSO only

Infos:

  • Used Zammad version: 3.3
  • Used Zammad installation source: apt
  • Operating system: Ubuntu 18.04
  • Browser + version:

Expected behavior:

  • Disable the password based logins and allow SSO like Google or Github only.

Actual behavior:

  • Login form displays username and password forms

Steps to reproduce the behavior:

  • The login page
2 Likes

I guess that’s a feature request.
It’s technically not possible to disable specific available login methods as of now.

I did the following for a temporary workaround

  • Enable the SSO Login provider
  • Disable from nginx, the Login URL endpoint that zammad was providing