Default create option email by sending emails to system


  • Operating system: Centos 7

Expected behavior:

  • should be created like email when system receives email

Actual behavior:

  • seems like it is created like incomming phonecall

Steps to reproduce the behavior:

  • Send email to ticket system

I have made this change in ruby console, witch sets de default option to email in GUI when manual creating ticket but does not affect when tickets are created by sending emails to system:

Setting.set(‘ui_ticket_create_default_type’, ‘email-out’)

Reason why I need to change this is because if the ticket is not created with email-out option reply to all option is missing.

Any update on this one:

The setting you’re referencing on is a UI setting only.
Naturally it only affects ticket creation by agents via Zammads UI.

Zammad will always ignore it’s own email address.
This is by design and not a bug - you can read more about that background and why here:

Basically it doesn’t make any sense to reply to your own email address, because it would create a follow up on the same ticket leading to duplicate information.

Above mentioned issue is marked as enhancement.
Pleae note that we can’t and won’t provide any ETAs on issues at all.

We will update issues accordingly as anything starts to move on them.
I suggest to subscribe to the issue in question if you want to get notified on changes.

yes, it seems like the function always was there but I did not see it.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.