Debian-Apt-Repository doesn't work in IPv6-only environments

Infos:

  • Used Zammad version: latest
  • Used Zammad installation type: package from https://dl.packager.io
  • Operating system: Debian Bullseye
  • Browser + version:

Expected behavior:

  • apt should do an update/upgrade in IPv6 only enviroments
  • AAAA-Entry for dl.packager.io should exist

Actual behavior:

  • apt-get udpate doesn’t work:
root@ticket ~# apt-get update

OK:1 http://security.debian.org/debian-security bullseye-security InRelease
Fehl:2 https://dl.packager.io/srv/deb/zammad/zammad/stable/debian 10 InRelease              
  »dl.packager.io« konnte nicht aufgelöst werden.
OK:3 https://artifacts.elastic.co/packages/7.x/apt stable InRelease                         
OK:4 http://deb.debian.org/debian bullseye InRelease       
OK:5 http://deb.debian.org/debian bullseye-updates InRelease
Paketlisten werden gelesen… Fertig
W: Fehlschlag beim Holen von https://dl.packager.io/srv/deb/zammad/zammad/stable/debian/dists/10/InRelease »dl.packager.io« konnte nicht aufgelöst werden.
W: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder alte an ihrer Stelle benutzt.
  • No AAAA-DNS:
root@ticket ~# dig dl.packager.io AAAA +noall +answer
dl.packager.io.		120	IN	CNAME	production.ouestcode.com.

root@ticket ~# dig production.ouestcode.com A +noall +answer
production.ouestcode.com. 115	IN	A	178.63.71.248

root@ticket ~# dig production.ouestcode.com AAAA +noall +answer
root@ticket ~# 

Steps to reproduce the behavior:

  • Drop you legacy IP and try apt-get update
  • Try dig production.ouestcode.com AAAA +noall +answer

This is a thirdparty issue (packager.io) and not a direct Zammad issue sorry.

Perhaps you can give packager.io a hint to fix this? It is the “official” repo from your documentation and not supporting IPv6 in 2021 is so 2000 :wink:

I’ll see when I find time for this.
You’ll be much faster if you do it on your own - I won’t lie to you.

1 Like

So I was busy with packager any way and was so keen and asked for you.
This is the reply:

(…) Regarding IPv6 for dl.packager.io, it will happen, but not sure yet when. (…)

So ETA unknown.

Thank you for asking.

Besten Dank!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.