Database backup script error


#1
  • Used Zammad version: 1.4
  • Operating system: Debian GNU/Linux 8.10 (jessie)
  • Browser + version: Firefox (66.0.3 (64-bit))

I have a problem with backup script and i also not a big Linux and script knowledge guy. I cant upgrade 1.4 to 2.9 so i tried to migrate all content on new machine with Debian 9 with installed Zammad 2.9. When run backup scrip i got this DB Adapter problem. Can someone help me what to do to get two filed need to restore on 2.9 Zammad i only get _zammad_files.tar.gz not database .tar.gz? This is script output “error”

/opt/zammad/contrib/backup# ./zammad_backup.sh
tar: Removing leading `/’ from member names
tar: /opt/zammad/tmp/cache_file_store_production: file changed as we read it
DB ADAPTER not found. if its sqlite backup is already saved in filebackup


#2

What database are you using with Zammad?
This information is completely missing, beside the installation type (package, (Docker), source).

You might want to check that in /opt/zammad/config/database.yml
Also, is the backup script originally shipped with that version?