Data under manage (channels, chats, users) nothing to see except "loading"

  • Used Zammad version: 3.3.0
  • Used Zammad installation source: docker-compose
  • Operating system: Debian
  • Browser + version: FF

Expected behavior:

  • Zammad usable normally

Actual behavior:

  • Logging into Zammad is now possible and there is no more CSRF error.
    Unfortunately, I can click on all menu items, but on the right side there is only “Loading”

I add the composer-override file so that you can quickly understand it.

It seems that he does not get the data that he wants to display in Admin under Settings. I can’t display a channel or users.

The CSRF error no longer occurs and I can log out and log in. But apparently eight tobacco here something else wrong?

I can also find nothing in the logs in the volume / var / libs / volumes / zammad-data. These are apparently not written.

Steps to reproduce the behavior:

Here my Docker-Compose-override
version: ‘2’
services:

  zammad-backup:
    container_name: Zammad-Backup

  zammad-elasticsearch:
    container_name: Zammad-ElasticSearch

  zammad-init:
    container_name: Zammad-Init

  zammad-memcached:
    container_name: Zammad-MemCached

  zammad-postgresql:
    container_name: Zammad-PostgreSQL

  zammad-railsserver:
    container_name: Zammad-RailsServer

  zammad-scheduler:
    container_name: Zammad-Scheduler

  zammad-websocket:
    container_name: Zammad-WebSocket

  zammad-nginx:
    container_name: Zammad-NGINX
    labels:
      traefik.enable: true

      # Routers
      traefik.http.routers.zammad-nginx.rule: Host(`service.example.com`)
      traefik.http.routers.zammad-nginx.entrypoints: websecure
      traefik.http.routers.zammad-nginx.tls.certresolver: myresolver
      traefik.http.routers.zammad-nginx.service: zammad_svc

      traefik.http.services.zammad_svc.loadBalancer.server.port: 80
      traefik.http.routers.zammad-nginx.middlewares: zammadHeader
      traefik.http.middlewares.zammadHeader.headers.customrequestheaders.X-Forwarded-Proto: https
      traefik.http.middlewares.zammadHeader.headers.customrequestheaders.X-Forwarded-Ssl: on
      traefik.http.middlewares.zammadHeader.headers.customrequestheaders.X-Forwarded-Port: 443

  traefik:
    image: traefik:v2.1
    container_name: Traefik
    command:
      - "--log.level=INFO"
      - "--api"
      - "--providers.docker=true"
      - "--providers.docker.exposedbydefault=false"
      - "--entrypoints.web.address=:80"
      - "--entrypoints.websecure.address=:443"
      - "--certificatesresolvers.myresolver.acme.httpchallenge=true"
      - "--certificatesresolvers.myresolver.acme.httpchallenge.entrypoint=web"
      - "--certificatesresolvers.myresolver.acme.caserver=https://acme-v02.api.letsencrypt.org/directory"
      - "--certificatesresolvers.myresolver.acme.email=infos@example.de"
      - "--certificatesresolvers.myresolver.acme.storage=/letsencrypt/acme.json"

    ports:
      - 80:80
      - 443:443
    volumes:
      - ./letsencrypt:/letsencrypt
      - /var/run/docker.sock:/var/run/docker.sock:ro
    labels:
      traefik.enable: true

      # Routers
      traefik.http.routers.traefik.rule: Host(`traefik.example.de`)
      traefik.http.routers.traefik.entrypoints: websecure
      traefik.http.routers.traefik.service: api@internal
      traefik.http.routers.traefik.tls.certresolver: myresolver
      traefik.http.routers.traefik.middlewares: traefik-auth

      # global redirect to https
      traefik.http.routers.http-catchall.rule: hostregexp(`{host:.+}`)
      traefik.http.routers.http-catchall.entrypoints: web
      traefik.http.routers.http-catchall.middlewares: redirect-to-https

      # Middleware
      traefik.http.middlewares.traefik-auth.basicauth.removeheader: true
      traefik.http.middlewares.traefik-auth.basicauth.users: csaeum:$$1$$X[kMyb^l$$Npy/uslnNuMB4pK0focS00

      # middleware redirect
      traefik.http.middlewares.redirect-to-https.redirectscheme.scheme: https

  portainer:
    image: portainer/portainer
    container_name: Portainer
    command: -H unix:///var/run/docker.sock
    restart: always
    volumes:
      - /var/run/docker.sock:/var/run/docker.sock
      - portainer_data:/data
    labels:
      traefik.enable: true

      # Routers
      traefik.http.routers.portainer.rule: Host(`portainer.example.de`)
      traefik.http.routers.portainer.entrypoints: websecure
      traefik.http.routers.portainer.tls.certresolver: myresolver
      traefik.http.routers.portainer.service: portainer_svc

      traefik.http.services.portainer_svc.loadBalancer.server.port: 9000

volumes:
  portainer_data:

Ok finally found.

in the document it is in the last paragraph:

Port compatibility error

 The nginx container may have compatibility problems with other machines or services pointing to port 0.0.0.0:80. So to fix this, we'll just have to modify the file docker-compose.override.yml and select different ports

Therefore I have inserted or rewritten this in the override:

zammad-nginx:
container_name: Zammad-NGINX
> ports:
> - "88:88"
labels:
traefik.enable: true

  # Routers
  traefik.http.routers.zammad-nginx.rule: Host(`service.leather-fabrics-online.com`)
  traefik.http.routers.zammad-nginx.entrypoints: websecure
  traefik.http.routers.zammad-nginx.tls.certresolver: myresolver
  traefik.http.routers.zammad-nginx.service: zammad_svc

  traefik.http.services.zammad_svc.loadBalancer.server.port: 80

traefik.http.routers.zammad-nginx.middlewares: zammadHeader

traefik.http.middlewares.zammadHeader.headers.customrequestheaders.X-Forwarded-Proto: https

traefik.http.middlewares.zammadHeader.headers.customrequestheaders.X-Forwarded-Ssl: on

traefik.http.middlewares.zammadHeader.headers.customrequestheaders.X-Forwarded-Port: 443

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.