Core Workflow Not Loading

Infos:

  • Used Zammad version: 5.0.x
  • Used Zammad installation type: package
  • Operating system: Debian 10 (Buster)
  • Browser + version: Chrome Version 95.0.4638.54 (Official Build) (64-bit)

Expected behavior:

  • Core Workflow to load

Actual behavior:

  • Core Workflow sits on “Loading”

Steps to reproduce the behavior:

  • Upgrade from 4.0.x to 5.0.x using apt-get update / apt get upgarde

Have checked the logs and cannot see any errors occurring.

Ensure to follow the update documentation:
https://docs.zammad.org/en/latest/install/update.html

I did follow the update documentation, exactly.
I wouldn’t be posting here otherwise asking for assistance.

Also just discovered after the update, tickets can’t be updated. Click the Update button on a ticket and nothing happens.

We have exactly the same problem.

After the upgrade; update button is not working anymore.
Pending reminder is now mandatory?
We see all users instead of only the users of the certain group.

Error message in the logs is:
E, [2021-10-29T09:54:49.638403 #26319-323320] ERROR – : Error performing Core Workflow engine.
E, [2021-10-29T09:54:49.638472 #26319-323320] ERROR – : PG::UndefinedTable: ERROR: relation “core_workflows” does not exist
LINE 8: WHERE a.attrelid = ‘“core_workflows”’::regclass
^
(ActiveRecord::StatementInvalid)
app/models/core_workflow.rb:8:in block in <class:CoreWorkflow>' app/models/core_workflow/result.rb:25:in workflows’
app/models/core_workflow/result.rb:65:in run' app/models/core_workflow.rb:20:in perform’
app/models/ticket/screen_options.rb:99:in attributes_to_change' app/controllers/tickets_controller.rb:663:in ticket_all’
app/controllers/tickets_controller.rb:66:in show' app/controllers/application_controller/has_download.rb:21:in block (4 levels) in module:HasDownload
app/controllers/application_controller/has_download.rb:20:in block (3 levels) in <module:HasDownload>' app/controllers/application_controller/has_download.rb:19:in block (2 levels) in module:HasDownload
app/controllers/application_controller/handles_transitions.rb:16:in `handle_transaction’

Yes, forgot to mention the Pending Update field being mandatory when updating a ticket. Why? it shouldn’t be there unless the ticket is set to being in a “Hold” or Waiting on Customer/Other Department/Vendor" (or similar) state.

I figured out the problem.
Zammad 5.0.x requires Ruby 2.7.4 as per Software — Zammad documentation.
Debian Buster (10) only comes with Ruby 2.5.5.
Need to upgrade Debain to Bullseye (11), then re-install Zammad (database and LDAP settings will be preserved).
I sued this guide to upgrade to Bullseye - https://www.linuxtechi.com/how-to-upgrade-debian-10-to-debian-11/
After rebooting run apt-get install --reinstall zammad
Core Workflow page is now loading, tickets can be updated, and the Pending Remidner field is gone.
Hope this helps others.

1 Like

Package installations come with pre-shipped Ruby environments.
This means you do not have to full fill this requirement. Following the package installation documentation is enough.
https://docs.zammad.org/en/latest/install/package.html

As you’re using a package installation, let me tell you this:
Zammad does not officially support Debian 11.
You’re probably abusing the Debian 10 repository for that which may or may not work.

If this is a productive installation you should switch back to supported paths:
https://docs.zammad.org/en/latest/prerequisites/software.html#supported-distributions

As packages come with pre shipped stuff your approach may break in the near future. You have been warned.


Looks like your migrations didn’t complete successfully which is why a reinstall or even an update installation on your Debian 10 installation should have worked too.

Never ever run installations and updates of Zammad unattended. You’ll then have the chance to see those kind of errors during the installation.

My issue was up for at least a week, and the only time someone from Zammad officially comments is when I find a solution that works that’s nto to their liking, instead of actually suggesting ways to fix the broken upgrade.

As I mentioned initially, yes, I followed the update instructions exactly, and lots of things broke, but no solution was forthcoming from anyone.

So I found my own solution which works.

The upgrade on Debian 10 did NOT certainly work and had many issues. And I tried various things to fix it and made it worse, including some of your suggestion.

Upgrading to Debian 11 fixed all the issues, and, after doing some research on various forums, including Stack Overflow, the above solution that I posted is what works.

Someone even posted the same issue that I had on your Git instance as an Issue, and it was closed down as saying it was a technical problem, not a bug. But if multiple people are having the same issue, then it is a bug that needs fixing, as something is definitely going wrong with the upgrade for the packaged version on Debian 10.

We have it working now using the above-posted method, and that’s all that matters right now as I have a bunch of other things to work on, including learning how Core Workflows work because the official documentation on it is very lacking in detail, so I don’t have time to downgrade back to Debian 10 and Zammad 4.0 to try something that I know will not work.

So, instead of reprimanding and shaming, how about providing some actual technical assistance and suggest solutions that actually fix the things the upgrade breaks on Debian 10 for those that experience the same issues I did/

Also, saying unattended upgrades are not to be performed goes against all automation and efficiency protocols.

Okay mate, sorry for pointing out important things.

Just a small side note for you so you don’t get wrong ideas:

  • nobody is obliged to reply to your threads, no matter how hot the fire on your instance is
  • this is a free community
    • Zammad staff does reply to posts on here, however, does not guarantee any solutions or reply times - if you’re not happy with that you may want to consider to choose paid support.
  • please understand that my aim is to keep you on supported paths to provide help as far as possible

For me this is the last time I’ve bothered you. Again, sorry that it was not to your liking.

I know it;'s a free community, and no one from the Zammad team is obliged to answer, but you did, and you did it in a very inflammatory way.

“You have been warned” and similar comments are not helpful.

Be polite. Be respectful. Be helpful, not accusatory.

Don’t antagonise your customers. Help them.

2 Likes

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.