Chat - Websocket Handshake Error


  • Used Zammad version: 04-01-18 (2.2.x)
  • Used Zammad installation source: Docker
  • Operating system: Ubuntu 17.04 LTS (Host)
  • Browser + version: Chrome 63 (Stable)

Expected behavior:

  • For the websocket to connect normally.

Actual behavior:

  • Websocket receives an unexpected error (502) upon handshake

Some detail on my setup:

My main setup is using Apache 2.4, and as such, I am reverse proxying traffic to the Docker container.

I believe that is the source of the problem but sadly, I am unable to currently change my setup. Do you happen to know a way to transfer the websocket connections via the reverse proxy?

Hi there, i already tried to reverse proxy via a Docker install of Zammad, but this isn’t the type of installation that is the most flexible.

Yes the performances are pretty good, but you’ll have to docker-compose run ou docker-compose exec a shell into the container that has the websocket config inside of it (i don’t recall the exact same name) BUT : every time you’ll fully restart your server, the files won’t be backed-up !

You’ll have to patch your docker installation with local files that corresponds to your config, then purge your docker cache and rebuild the full installation inside the docker in order to deploy the right files.

Warning : this is me and my small experience of it, few days spent sweating on it, then i realized that i didn’t need it compressed, so i went for a DEB install => :slight_smile:

Good luck !

Have you tried installing

to see if this fixes your problem?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.