Can't find the Knowledge Base

  • Used Zammad version: 3.2.x
  • Used Zammad installation source: DEB
  • Operating system: Ubuntu 18.04.
  • Browser + version: Firefox 68.0.1

Actual behavior:

I can’t find the optionen to activate the Knowledge Base in Zammad. On my Adminpanel there is no option or topic to activate. A bookmark is also not there on left side.
Even after an update from Zammad with DEB, i couldn’t get the Knowledge Base.

Anyone got an idea how i could install the Knowledge Base?

Please note that Zammad 3.2 is the develop and currently not stable.
If you’re on a production environment, you might want to run the stable version.

You can find the knowledgebase-options inside the admin menu (tool gear on the lower left) underneath time accounting:

If you can’t find this option on a current 3.x installation, I suppose that you where Upgrading from earlier 3.x. If so, it’s possible the migration somewhere died.

I will now use the KB but i make a migration to version 3.1 and the button is not there

i update from 1.5 to the latest version 3.1 my system is debian 9
zammad 3.1.0-1572420711.b7bfdcd4.stretch is my version

Please don’t hijack solved threads.
Besides, during installation I’m sure something went wrong, your console log should show.

If you closed your session already (because I guess you didn’t check the output), you can also rerun the following:

/opt/zammad/contrib/packager.io/postinstall.sh

Furthermore, please provide logfiles or anything helpfull, right now this is bare fishing in the dark.

> root@ticket-senn:/var/tmp/zammad_backup# /opt/zammad/contrib/packager.io/postinstall.sh
> (Re)creating init scripts
>Nothing to do.
Nothing to do.
Nothing to do.
 Enabling Zammad on boot
 Stopping Zammad
 database.yml found. Updating db...
 Updating translations...
 Configuring Elasticsearch...
-> removing [ingest-attachment]...
-> Downloading ingest-attachment from elastic
[=================================================] 100%  
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@     WARNING: plugin requires additional permissions     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
* java.lang.RuntimePermission accessClassInPackage.sun.java2d.cmm.kcms
* java.lang.RuntimePermission accessDeclaredMembers
* java.lang.RuntimePermission getClassLoader
* java.lang.reflect.ReflectPermission suppressAccessChecks
* java.security.SecurityPermission createAccessControlContext
* java.security.SecurityPermission insertProvider
* java.security.SecurityPermission putProviderProperty.BC
See http://docs.oracle.com/javase/8/docs/technotes/guides/security/permissions.html
for descriptions of what these permissions allow and the associated risks.
-> Installed ingest-attachment
 Starting Zammad
 Creating webserver bootstart
Synchronizing state of nginx.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable nginx
 Restarting webserver nginx
####################################################################################

Add your fully qualified domain name or public IP to servername directive of
nginx, if this installation is done on a remote server. You have to change:
/etc/nginx/sites-available/zammad.conf and restart nginx process.
Otherwise just open http://localhost/ in your browser to start using Zamma

I have always this Warning but i see no errors

Try to clear the cache, that might help:
zammad run rails r 'Cache.clear'

Also, ensure to clear your Browser cache with reloading the WebApp.
If the issue persists, check your role rights that might be missing user rights that deny you seeing the menu point.

I dont see it :frowning:

Clear the cache and ensure to completely reload your browsers page to ensure your browser is not the evil caching point.

If that doesn’t help, take a look into your developer console if it does throw significant errors.
You could also try zammad run rake assets:precompile (possibly followed by another clearing cache) and check again.