"Cannot define multiple ‘included’ blocks for a Concern" when importing a backup on a new server

Infos:

  • Used Zammad version: Latest version from Ubuntu package
  • Used Zammad installation source: Ubuntu package
  • Operating system: Ubuntu 20.04
  • Browser + version: NA

Issue

When importing a backup on a new server, I have the following error after cache clearing. The tool indicates then that the import is working fine, but it’s not.

# Clearing Cache ...
Traceback (most recent call last):
	73: from /opt/zammad/bin/rails:9:in `<main>'
	72: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `require'
	71: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:257:in `load_dependency'
	70: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `block in require'
	69: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
	68: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
	67: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
	66: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
	65: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
	64: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/commands.rb:18:in `<main>'
	63: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/command.rb:46:in `invoke'
	62: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/command/base.rb:69:in `perform'
	61: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/thor-1.1.0/lib/thor.rb:392:in `dispatch'
	60: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/thor-1.1.0/lib/thor/invocation.rb:127:in `invoke_command'
	59: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/thor-1.1.0/lib/thor/command.rb:27:in `run'
	58: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/commands/runner/runner_command.rb:29:in `perform'
	57: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/command/actions.rb:15:in `require_application_and_environment!'
	56: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/command/actions.rb:28:in `require_environment!'
	55: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/application.rb:337:in `require_environment!'
	54: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `require'
	53: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:257:in `load_dependency'
	52: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `block in require'
	51: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
	50: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
	49: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
	48: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
	47: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
	46: from /opt/zammad/config/environment.rb:5:in `<main>'
	45: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/application.rb:361:in `initialize!'
	44: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/initializable.rb:60:in `run_initializers'
	43: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:205:in `tsort_each'
	42: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:226:in `tsort_each'
	41: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `each_strongly_connected_component'
	40: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `call'
	39: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `each'
	38: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:349:in `block in each_strongly_connected_component'
	37: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:431:in `each_strongly_connected_component_from'
	36: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:350:in `block (2 levels) in each_strongly_connected_component'
	35: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:228:in `block in tsort_each'
	34: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/initializable.rb:61:in `block in run_initializers'
	33: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/initializable.rb:32:in `run'
	32: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/initializable.rb:32:in `instance_exec'
	31: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/application/finisher.rb:69:in `block in <module:Finisher>'
	30: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/application/finisher.rb:69:in `each'
	29: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/engine.rb:356:in `eager_load!'
	28: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/engine.rb:475:in `eager_load!'
	27: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/engine.rb:475:in `each'
	26: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/engine.rb:477:in `block in eager_load!'
	25: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/engine.rb:477:in `each'
	24: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/engine.rb:478:in `block (2 levels) in eager_load!'
	23: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:246:in `require_dependency'
	22: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:80:in `depend_on'
	21: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:334:in `depend_on'
	20: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:45:in `require_or_load'
	19: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:16:in `allow_bootsnap_retry'
	18: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:46:in `block in require_or_load'
	17: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:356:in `require_or_load'
	16: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:37:in `load_interlock'
	15: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies/interlock.rb:13:in `loading'
	14: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/concurrency/share_lock.rb:151:in `exclusive'
	13: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies/interlock.rb:14:in `block in loading'
	12: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:37:in `block in load_interlock'
	11: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:378:in `block in require_or_load'
	10: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `require'
	 9: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:257:in `load_dependency'
	 8: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `block in require'
	 7: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
	 6: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
	 5: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
	 4: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
	 3: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
	 2: from /opt/zammad/app/models/concerns/tag/writes_to_ticket_history.rb:4:in `<main>'
	 1: from /opt/zammad/app/models/concerns/tag/writes_to_ticket_history.rb:7:in `<module:WritesToTicketHistory>'
/opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/concern.rb:130:in `included': Cannot define multiple 'included' blocks for a Concern (ActiveSupport::Concern::MultipleIncludedBlocks)

When looking at the logs, I can see that the Zammad-web.service can’t start and it displays the same error « Cannot define multiple ‘included’ blocks for a Concern ». Here’s a sample of the logs :

Mar 26 16:00:15 vps-d29b8e47 systemd[1]: Started zammad-worker-1.service.
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]: Exiting
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]: bundler: failed to load command: script/rails (script/rails)
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]: ActiveSupport::Concern::MultipleIncludedBlocks: Cannot define multiple 'included' blocks for a Concern
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/concern.rb:130:in `included'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/app/models/concerns/tag/writes_to_ticket_history.rb:7:in `<module:WritesToTicketHistory>'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/app/models/concerns/tag/writes_to_ticket_history.rb:4:in `<main>'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `block in require'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:257:in `load_dependency'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `require'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:378:in `block in require_or_load'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:37:in `block in load_interlock'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies/interlock.rb:14:in `block in loading'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/concurrency/share_lock.rb:151:in `exclusive'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies/interlock.rb:13:in `loading'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:37:in `load_interlock'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:356:in `require_or_load'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:46:in `block in require_or_load'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:16:in `allow_bootsnap_retry'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:45:in `require_or_load'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:334:in `depend_on'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:80:in `depend_on'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:246:in `require_dependency'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/engine.rb:478:in `block (2 levels) in eager_load!'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/engine.rb:477:in `each'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/engine.rb:477:in `block in eager_load!'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/engine.rb:475:in `each'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/engine.rb:475:in `eager_load!'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/engine.rb:356:in `eager_load!'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/application/finisher.rb:69:in `each'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/application/finisher.rb:69:in `block in <module:Finisher>'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/initializable.rb:32:in `instance_exec'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/initializable.rb:32:in `run'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/initializable.rb:61:in `block in run_initializers'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:228:in `block in tsort_each'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:350:in `block (2 levels) in each_strongly_connected_component'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:431:in `each_strongly_connected_component_from'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:349:in `block in each_strongly_connected_component'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `each'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `call'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `each_strongly_connected_component'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:226:in `tsort_each'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:205:in `tsort_each'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/initializable.rb:60:in `run_initializers'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/application.rb:361:in `initialize!'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/config/environment.rb:5:in `<main>'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `block in require'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:257:in `load_dependency'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `require'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   config.ru:3:in `block in <main>'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/rack-2.2.3/lib/rack/builder.rb:116:in `eval'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/rack-2.2.3/lib/rack/builder.rb:116:in `new_from_string'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/rack-2.2.3/lib/rack/builder.rb:105:in `load_file'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/rack-2.2.3/lib/rack/builder.rb:66:in `parse_file'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/rack-2.2.3/lib/rack/server.rb:349:in `build_app_and_options_from_config'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/rack-2.2.3/lib/rack/server.rb:249:in `app'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/commands/server/server_command.rb:27:in `app'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/rack-2.2.3/lib/rack/server.rb:422:in `wrapped_app'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/rack-2.2.3/lib/rack/server.rb:312:in `block in start'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/rack-2.2.3/lib/rack/server.rb:379:in `handle_profiling'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/rack-2.2.3/lib/rack/server.rb:311:in `start'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/commands/server/server_command.rb:53:in `start'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/commands/server/server_command.rb:147:in `block in perform'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/commands/server/server_command.rb:142:in `tap'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/commands/server/server_command.rb:142:in `perform'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/thor-1.1.0/lib/thor/command.rb:27:in `run'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/thor-1.1.0/lib/thor/invocation.rb:127:in `invoke_command'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/thor-1.1.0/lib/thor.rb:392:in `dispatch'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/command/base.rb:69:in `perform'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/command.rb:46:in `invoke'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.5/lib/rails/commands.rb:18:in `<main>'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `block in require'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:257:in `load_dependency'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.5/lib/active_support/dependencies.rb:291:in `require'
Mar 26 16:00:18 vps-d29b8e47 zammad-web-1.service[20190]:   script/rails:6:in `<top (required)>'
Mar 26 16:00:18 vps-d29b8e47 systemd[1]: zammad-web-1.service: Main process exited, code=exited, status=1/FAILURE
Mar 26 16:00:18 vps-d29b8e47 systemd[1]: zammad-web-1.service: Failed with result 'exit-code'.
Mar 26 16:00:18 vps-d29b8e47 systemd[1]: zammad-web-1.service: Scheduled restart job, restart counter is at 64.
Mar 26 16:00:18 vps-d29b8e47 systemd[1]: Stopped zammad-web-1.service.

The two servers are very close, the only major difference is the Ubuntu version (18.04 on the old one, 20.04 on the new one). Except that, Zammad was installed on both using the Ubuntu package and so must be at the same state right now. The Elasticsearch version is also the same.

I don’t think it’s an error on my part, but maybe I missed something ? I searched he specific error here and on GitHub issues, but found nothing.

Thanks !

Same issue still with the latest update :

Unpacking zammad (4.0.0-1616833066.ac840931.focal) over (4.0.0-1616711796.64aca6cc.focal) ...

Am I the only one ?

Above errors are perfectly normal because you’re restoring source files on a system that does not support those. You’re basically breaking your installation. You’ll have to run a forced reinstall after restoring your backup to solve this issue.

We also state that in the documentation:
https://docs.zammad.org/en/latest/appendix/backup-and-restore.html#what-to-do-after-restoration-has-been-completed

After you complete those steps you should be good to go.

I don’t understand what you mean with that. What is wrong exactly with my source files ?

I already tried reinstalling Zammad and it does not work. The same error is still present, even during the reinstallation process.

What I don’t get is that we have used the export/import tools in the past and it worked fine. Is there something that has changed recently ?

Zammads backup script is creating a dump of /opt/zammad/.
During restoration, we replace all files from within the backup to /opt/zammad.

This means that we technically break the installation by putting old files in place.

The reason for that will be that you’re switching your distribution as well!
Software dependencies on both systems to technically differ, not only in terms of the pre shipped ruby gems etc. This is why you need to force a reinstallation if your destination is different than the source. (Yes, Ubuntu 18 and Ubuntu 20 are a difference as well).

You didn’t happen to copy the repository file from your old host, did you?
Please ensure that you’re using the Ubuntu 20 version.
Please see the documentation for the correct, current URL: Install from package — Zammad documentation

After restoration and followed reinstallation you can check if Zammad is fine by simply running zammad run rails c. If the rails console comes on cleanly you’re good.

Let’s then start from there.

Thanks for your help and the detailed answer. :slightly_smiling_face:

So I just tried to import data again.

After the restore operation on the new server, the same error as before, no problem there :

# Restoring Files
# Ensuring correct file rights ...
# Clearing Cache ...
Traceback (most recent call last):
	73: from /opt/zammad/bin/rails:9:in `<main>'
	72: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `require'
	71: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:257:in `load_dependency'
	70: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `block in require'
	69: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
	68: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
	67: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
	66: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
	65: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
	64: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/commands.rb:18:in `<main>'
	63: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/command.rb:46:in `invoke'
	62: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/command/base.rb:69:in `perform'
	61: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/thor-1.1.0/lib/thor.rb:392:in `dispatch'
	60: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/thor-1.1.0/lib/thor/invocation.rb:127:in `invoke_command'
	59: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/thor-1.1.0/lib/thor/command.rb:27:in `run'
	58: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/commands/runner/runner_command.rb:29:in `perform'
	57: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/command/actions.rb:15:in `require_application_and_environment!'
	56: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/command/actions.rb:28:in `require_environment!'
	55: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/application.rb:337:in `require_environment!'
	54: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `require'
	53: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:257:in `load_dependency'
	52: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `block in require'
	51: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
	50: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
	49: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
	48: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
	47: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
	46: from /opt/zammad/config/environment.rb:5:in `<main>'
	45: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/application.rb:361:in `initialize!'
	44: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/initializable.rb:60:in `run_initializers'
	43: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:205:in `tsort_each'
	42: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:226:in `tsort_each'
	41: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `each_strongly_connected_component'
	40: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `call'
	39: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `each'
	38: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:349:in `block in each_strongly_connected_component'
	37: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:431:in `each_strongly_connected_component_from'
	36: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:350:in `block (2 levels) in each_strongly_connected_component'
	35: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:228:in `block in tsort_each'
	34: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/initializable.rb:61:in `block in run_initializers'
	33: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/initializable.rb:32:in `run'
	32: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/initializable.rb:32:in `instance_exec'
	31: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/application/finisher.rb:69:in `block in <module:Finisher>'
	30: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/application/finisher.rb:69:in `each'
	29: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:356:in `eager_load!'
	28: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:475:in `eager_load!'
	27: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:475:in `each'
	26: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:477:in `block in eager_load!'
	25: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:477:in `each'
	24: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:478:in `block (2 levels) in eager_load!'
	23: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:246:in `require_dependency'
	22: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:80:in `depend_on'
	21: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:334:in `depend_on'
	20: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:45:in `require_or_load'
	19: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:16:in `allow_bootsnap_retry'
	18: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:46:in `block in require_or_load'
	17: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:356:in `require_or_load'
	16: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:37:in `load_interlock'
	15: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies/interlock.rb:13:in `loading'
	14: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/concurrency/share_lock.rb:151:in `exclusive'
	13: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies/interlock.rb:14:in `block in loading'
	12: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:37:in `block in load_interlock'
	11: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:378:in `block in require_or_load'
	10: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `require'
	 9: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:257:in `load_dependency'
	 8: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `block in require'
	 7: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
	 6: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
	 5: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
	 4: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
	 3: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
	 2: from /opt/zammad/app/models/concerns/tag/writes_to_ticket_history.rb:4:in `<main>'
	 1: from /opt/zammad/app/models/concerns/tag/writes_to_ticket_history.rb:7:in `<module:WritesToTicketHistory>'
/opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/concern.rb:130:in `included': Cannot define multiple 'included' blocks for a Concern (ActiveSupport::Concern::MultipleIncludedBlocks)
# Starting Zammad

# Zammad restored successfully - Fri 21 May 2021 05:11:25 PM CEST!

I then removed Zammad using the command given in the doc and then reinstalled it. During the process, here’s the error I got :

# Ensuring correct file rights ...
# Clearing Cache ...
Traceback (most recent call last):
	73: from /opt/zammad/bin/rails:9:in `<main>'
	72: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `require'
	71: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:257:in `load_dependency'
	70: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `block in require'
	69: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
	68: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
	67: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
	66: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
	65: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
	64: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/commands.rb:18:in `<main>'
	63: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/command.rb:46:in `invoke'
	62: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/command/base.rb:69:in `perform'
	61: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/thor-1.1.0/lib/thor.rb:392:in `dispatch'
	60: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/thor-1.1.0/lib/thor/invocation.rb:127:in `invoke_command'
	59: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/thor-1.1.0/lib/thor/command.rb:27:in `run'
	58: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/commands/runner/runner_command.rb:29:in `perform'
	57: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/command/actions.rb:15:in `require_application_and_environment!'
	56: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/command/actions.rb:28:in `require_environment!'
	55: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/application.rb:337:in `require_environment!'
	54: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `require'
	53: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:257:in `load_dependency'
	52: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `block in require'
	51: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
	50: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
	49: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
	48: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
	47: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
	46: from /opt/zammad/config/environment.rb:5:in `<main>'
	45: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/application.rb:361:in `initialize!'
	44: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/initializable.rb:60:in `run_initializers'
	43: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:205:in `tsort_each'
	42: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:226:in `tsort_each'
	41: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `each_strongly_connected_component'
	40: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `call'
	39: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `each'
	38: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:349:in `block in each_strongly_connected_component'
	37: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:431:in `each_strongly_connected_component_from'
	36: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:350:in `block (2 levels) in each_strongly_connected_component'
	39: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `each'
	38: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:349:in `block in each_strongly_connected_component'
	37: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:431:in `each_strongly_connected_component_from'
	36: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:350:in `block (2 levels) in each_strongly_connected_component'
	35: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:228:in `block in tsort_each'
	34: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/initializable.rb:61:in `block in run_initializers'
	33: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/initializable.rb:32:in `run'
	32: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/initializable.rb:32:in `instance_exec'
	31: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/application/finisher.rb:69:in `block in <module:Finisher>'
	30: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/application/finisher.rb:69:in `each'
	29: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:356:in `eager_load!'
	28: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:475:in `eager_load!'
	27: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:475:in `each'
	26: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:477:in `block in eager_load!'
	25: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:477:in `each'
	24: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:478:in `block (2 levels) in eager_load!'
	23: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:246:in `require_dependency'
	22: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:80:in `depend_on'
	21: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:334:in `depend_on'
	20: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:45:in `require_or_load'
	19: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:16:in `allow_bootsnap_retry'
	18: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:46:in `block in require_or_load'
	17: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:356:in `require_or_load'
	16: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:37:in `load_interlock'
	15: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies/interlock.rb:13:in `loading'
	14: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/concurrency/share_lock.rb:151:in `exclusive'
	13: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies/interlock.rb:14:in `block in loading'
	12: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:37:in `block in load_interlock'
	11: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:378:in `block in require_or_load'
	10: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `require'
	 9: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:257:in `load_dependency'
	 8: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `block in require'
	 7: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
	 6: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
	 5: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
	 4: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
	 3: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
	 2: from /opt/zammad/app/models/concerns/tag/writes_to_ticket_history.rb:4:in `<main>'
	 1: from /opt/zammad/app/models/concerns/tag/writes_to_ticket_history.rb:7:in `<module:WritesToTicketHistory>'
/opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/concern.rb:130:in `included': Cannot define multiple 'included' blocks for a Concern (ActiveSupport::Concern::MultipleIncludedBlocks)
# Starting Zammad

It’s the same as the output of the zammad run rails c command :

Traceback (most recent call last):
	73: from bin/rails:9:in `<main>'
	72: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `require'
	71: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:257:in `load_dependency'
	70: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `block in require'
	69: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
	68: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
	67: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
	66: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
	65: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
	64: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/commands.rb:18:in `<main>'
	63: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/command.rb:46:in `invoke'
	62: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/command/base.rb:69:in `perform'
	61: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/thor-1.1.0/lib/thor.rb:392:in `dispatch'
	60: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/thor-1.1.0/lib/thor/invocation.rb:127:in `invoke_command'
	59: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/thor-1.1.0/lib/thor/command.rb:27:in `run'
	58: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/commands/console/console_command.rb:95:in `perform'
	57: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/command/actions.rb:15:in `require_application_and_environment!'
	56: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/command/actions.rb:28:in `require_environment!'
	55: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/application.rb:337:in `require_environment!'
	54: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `require'
	53: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:257:in `load_dependency'
	52: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `block in require'
	51: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
	50: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
	49: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
	48: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
	47: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
	46: from /opt/zammad/config/environment.rb:5:in `<main>'
	45: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/application.rb:361:in `initialize!'
	44: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/initializable.rb:60:in `run_initializers'
	43: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:205:in `tsort_each'
	42: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:226:in `tsort_each'
	41: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `each_strongly_connected_component'
	40: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `call'
	39: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:347:in `each'
	38: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:349:in `block in each_strongly_connected_component'
	37: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:431:in `each_strongly_connected_component_from'
	36: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:350:in `block (2 levels) in each_strongly_connected_component'
	35: from /opt/zammad/vendor/ruby-2.6.6/lib/ruby/2.6.0/tsort.rb:228:in `block in tsort_each'
	34: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/initializable.rb:61:in `block in run_initializers'
	33: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/initializable.rb:32:in `run'
	32: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/initializable.rb:32:in `instance_exec'
	31: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/application/finisher.rb:69:in `block in <module:Finisher>'
	30: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/application/finisher.rb:69:in `each'
	29: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:356:in `eager_load!'
	28: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:475:in `eager_load!'
	27: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:475:in `each'
	26: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:477:in `block in eager_load!'
	25: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:477:in `each'
	24: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/railties-5.2.4.6/lib/rails/engine.rb:478:in `block (2 levels) in eager_load!'
	23: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:246:in `require_dependency'
	22: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:80:in `depend_on'
	21: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:334:in `depend_on'
	20: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:45:in `require_or_load'
	19: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:16:in `allow_bootsnap_retry'
	18: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/active_support.rb:46:in `block in require_or_load'
	17: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:356:in `require_or_load'
	16: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:37:in `load_interlock'
	15: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies/interlock.rb:13:in `loading'
	14: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/concurrency/share_lock.rb:151:in `exclusive'
	13: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies/interlock.rb:14:in `block in loading'
	12: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:37:in `block in load_interlock'
	11: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:378:in `block in require_or_load'
	10: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `require'
	 9: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:257:in `load_dependency'
	 8: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/dependencies.rb:291:in `block in require'
	 7: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:29:in `require'
	 6: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:20:in `require_with_bootsnap_lfi'
	 5: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/loaded_features_index.rb:65:in `register'
	 4: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `block in require_with_bootsnap_lfi'
	 3: from /opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require'
	 2: from /opt/zammad/app/models/concerns/tag/writes_to_ticket_history.rb:4:in `<main>'
	 1: from /opt/zammad/app/models/concerns/tag/writes_to_ticket_history.rb:7:in `<module:WritesToTicketHistory>'
/opt/zammad/vendor/bundle/ruby/2.6.0/gems/activesupport-5.2.4.6/lib/active_support/concern.rb:130:in `included': Cannot define multiple 'included' blocks for a Concern (ActiveSupport::Concern::MultipleIncludedBlocks)

Let me know if you need more information from me.

Are you running the restoration a second time?
Because this is not what you should do.

Above messages and actions are not part of the installation / update process.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.