Autocomplete of users/companies does not work


  • Used Zammad version: 2.5.x
  • Used Zammad installation source: Debian 9 Package from
  • Operating system: Debian 9.4
  • Browser + version: Firefox 61.0.1 / Chromium 68.0.3440.84

Expected behavior:

  • Ticket create: Contacts should be proposed while typing in customer field
  • User edit: Companies should be proposed while typing in company field

Actual behavior:

  • Nothing happens while typing, existing users wont be displayed as suggestion

Steps to reproduce the behavior:

  • create ticket, type into user field
  • edit user, type into company field
1 Like

Is the overall search function for tickets working for you? Sounds rather strange.

1 Like

Not at all and I guess something with elasticsearch is broken. Does the autocomplete use elasticsearch, too?

I got an issue I found on several pages in the net but never found a solution.

Unable to process PUT request to elasticsearch URL 'http://localhost:9200/zammad_production'.

but elasticsearch is running and answers

# curl -X GET 'http://localhost:9200'
  "name" : "AgswWxg",
  "cluster_name" : "elasticsearch",
  "cluster_uuid" : "p4EWtdvPRGye-SXIaxqwdg",
  "version" : {
    "number" : "5.5.3",
    "build_hash" : "9305a5e",
    "build_date" : "2017-09-07T15:56:59.599Z",
    "build_snapshot" : false,
    "lucene_version" : "6.6.0"
  "tagline" : "You Know, for Search"

Disabling elasticsearch (the workaround in most of the posts I found about this) worked for me, too. Search and autocomplete now works, but I guess this is not the way it should be solved.

thanks in advance!

Hey no worries, I’m sure we’ll get that fixed.

Please follow the instructions on the following page:

Make sure that your elasticsearch does not get newer than 5.6 (but that’s fitting on your end so all good)

Lemme know if that helped. :slight_smile:

1 Like

Thanks :slight_smile:

That install howto is what I did, I followed the Debian 9 steps but could not get any connection to elasticsearch. Tried different ports, localhost and, etc.

My elasticsearch package is already pinned to 5.4.3

Could you please post the history and output of what you do while during that? Maybe we’ll find the error then :slight_smile:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.