Assets:precompile Nodejs yarn

  • Used Zammad version: 5.x
  • Used Zammad installation type: package
  • Operating system: CentOS 7

Expected behavior:
precompile work after install nodejs12 based on zammad help in following url:

https://docs.zammad.org/en/latest/install/package.html#optional-node-js

zammad run rake assets:precompile

Actual behavior:

error stylelint@14.1.0: The engine “node” is incompatible with this module. Expected version “^12.20.0 || ^14.13.1 || >=16.0.0”. Got “12.16.2”
error Found incompatible module.
info Visit yarn install | Yarn for documentation about this command.
rake aborted!

Steps to reproduce the behavior:
Based on zammad help,
Nodejs12 is installed correctly.
Node -v
v12.22.5

yarn -v
1.22.17

npm -v
8.5.4

Sorry about that. You may want to upgrade to v14 or better.
Documentation update will come some when after my vacation.

1 Like

Yes please.
Enjoy your vacation wishes.

This issue confused me.
I tried
nodejs 14.13.3
nodejs 12.20.0
nodejs 16.0.0
Same result and still get

zammad run rake assets:precompile
yarn install v1.22.17
[1/4] Resolving packages…
[2/4] Fetching packages…
error stylelint@14.1.0: The engine “node” is incompatible with this module. Expected version “^12.20.0 || ^14.13.1 || >=16.0.0”. Got “12.16.2”
error Found incompatible module.
info Visit yarn install | Yarn for documentation about this command.
rake aborted!

I noticed reason of issue. Its not relate to nodejs or yarn.
I will report it soon here.

Can you tell us all the reason for the issue, please?
And do you have a solution?

Even with node v16, I am getting the same error. I tried this from /home/zammad and from /opt/zammad:

root@server /home/zammad # zammad run rake assets:precompile
yarn install v1.22.18
[1/4] Resolving packages…
[2/4] Fetching packages…
error stylelint@14.1.0: The engine “node” is incompatible with this module. Expected version “^12.20.0 || ^14.13.1 || >=16.0.0”. Got “12.16.2”
error Found incompatible module.
info Visit yarn install | Yarn for documentation about this command.
root@server /home/zammad # yarn -v
1.22.18
root@server /home/zammad # node -v
v16.14.1

Yes, Sure.
I am using a custom font in my zammad , I add nwa-font.css to /opt/zammad/app/assets/stylesheets/custom
with following details

@font-face {
font-family: “IranSans”;
src: url("./fonts/IRANSansWeb.eot?#") format(“eot”), url("./fonts/IRANSansWeb.woff") format(“woff”), url("./fonts/IRANSansWeb.ttf") format(“truetype”);

font-family: "IranSansNum";
src:  url("./fonts/IRANSansWeb(FaNum).ttf") format("truetype");

}
body {
font-family: “IranSansNum”,“Tahoma” !important;
}

zammad run rake assets:precompile working fine with this modification on zammad 4.x but on zammad 5.x return error and rake aborted!
I don’t know why?! Maybe zammad team guys can help.
Although i must say with or without the custom css, Following essage showing but if i remove the css, assets:precompile will work fine and precompile other modifications.

error stylelint@14.1.0: The engine “node” is incompatible with this module. Expected version “^12.20.0 || ^14.13.1 || >=16.0.0”. Got “12.16.2”
error Found incompatible module.

Update : Same results on Zammad 5.1.0

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.