After updating to 4.0, tickets are no longer displayed

  • Used Zammad version: 4.0
  • Used Zammad installation source: source
  • Operating system: Ubuntu 20.04.1
  • Browser + version: Chrome latest

After updating to 4.0, tickets are no longer displayed.

same here.

If i run

zammad run rake searchindex:rebuild

i get an error.

rake aborted! Unable to send Ticket.find(17).search_index_update_backend backend: #<ActiveRecord::StatementInvalid: PG::UndefinedTable: ERROR: relation "mentions" does not exist

how can i fix it ?

I had the same problem but I think it was my mistake. I updated Elasticsearch first and when I updated Zammad I think the Elasticsearch service was stopped. All I had to do was do a yum reinstall zammad while Elastic was running and then the searchindex rebuild worked and Zammad works too.

4 Likes

This works for me. Thank you.

For me it works again after a new installation. Thank You!

It has worked for me, too. Thanks a lot.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.